Antwort schreiben 
Mein Browser verschluckt einzelne Kanji.
Verfasser Nachricht
Nagini


Beiträge: 4
Beitrag #1
Mein Browser verschluckt einzelne Kanji.
Hallo,

auf meinem Computer ist Japanisch installiert und ich kann es auch tippen. Mit japanischen Homepages wie der von amazon.co.jp habe ich keine Probleme.
Wenn ich aber hier im Forum oder auf anderen nichtjapanischen Seiten japanische Texte lese, ist ein Teil davon nur leere Kästchen. So wie hier:
[Bild: kanjischluckerey9.jpg]

Mein Browser verschluckt Kanji? Was ist da los? kratz

Die Codierung der Seite ist übrigens Unicode. Wenn ich Japanisch auswähle, kommt nur größerer Salat raus.
Wie kann ich das beheben? Ich will alles lesen können...

verzweifelte Grüße,
Nagini
01.02.07 17:32
Alle Beiträge dieses Benutzers finden Diese Nachricht in einer Antwort zitieren
zongoku
Inaktiv

Beiträge: 2.973
Beitrag #2
RE: Mein Browser verschluckt einzelne Kanji.
Ich tippe auf eine falsche Codierung deines Browsers.
Encoding und eventuell More "weitere moeglichkeiten auswaehlen" anklicken.

Da gibt es noch japanese Auto Select, Japanase EUC und Shift-Jis. Es koennten noch andere da sein.

Eben mal ausprobieren.

Da muesste dann ein Satz wie folgendes.

nihongo o narau tame ni, ima kara kono nihon de iroiro na bunpoo o tsukatte miru tsumori da.

Viel Glueck.
01.02.07 17:55
Alle Beiträge dieses Benutzers finden Diese Nachricht in einer Antwort zitieren
frostschutz
Technik

Beiträge: 1.661
Beitrag #3
RE: Mein Browser verschluckt einzelne Kanji.
(01.02.07 17:32)Nagini schrieb:Mein Browser verschluckt Kanji? Was ist da los? kratz

Bei Darstellungsproblemen gibts eigentlich nur zwei Möglichkeiten. Zum einen die Codierung - wenn du die falsche hast, merkst du das normalerweise ziemlich schnell, denn da hast du nur wirren Zeichensalat Mojibake auf dem Schirm. Die andere Möglichkeit ist die verwendete Schriftart. Wenn die Schriftart nicht das komplette Zeichenspektrum abdeckt, werden alle unbekannten Zeichen eben nicht oder falsch dargestellt. Wie das dann genau aussieht, ist systemabhängig - ich sehe bei mir in dem Fall z.B. ein Kästchen, in dem der Unicode-Code des unbekannten Zeichens steht. Kann gut sein, daß die leeren Kästchen bei dir von diesem Problem herrühren.

Eine dritte, aber eher nicht so wahrscheinliche Möglichkeit ist ein Bug in einem der an der Darstellung beteiligten Programme (Browser, Schriftrenderer, uvm). D.h. du hast zwar den richtigen Zeichensatz und die richtige Schrift installiert, aber irgendeines dieser Programme kommt damit nicht vollständig klar und produziert dann stellenweise Mist.

Ich würde an deiner Stelle mal prüfen, welche Schriftart(en) dein Browser auf den problematischen Seiten verwendet und ausprobieren, ob eine andere (Japanisch-)Schriftart dieses Problem löst. Zur Not kannst du es mal mit einer Schlagmichtot-Font wie Bitstream Cyberbit o.ä. versuchen.

Schreib bei so Fragen vielleicht auch mal dazu, welchen Browser du genau verwendest und auf welchem Betriebssystem und jeweils welche Versionen davon. Vielleicht sind ja irgendwelche Bugs bekannt.

Lernen ist wie Rudern gegen den Strom. Sobald man aufhört, treibt man zurück.
01.02.07 18:05
Alle Beiträge dieses Benutzers finden Diese Nachricht in einer Antwort zitieren
Nagini


Beiträge: 4
Beitrag #4
RE: Mein Browser verschluckt einzelne Kanji.
Danke für eure Antworten. Mein Browser ist übrigens der Internet Explorer 7, mit Windows XP.
Wenn ich die anderen Möglichkeiten für Japanisch ausprobiere (wie eben japanese Auto Select, Japanase EUC und Shift-Jis) kommt nur noch größerer Zeichensalat heraus.
Ich vermute eher, dass es am Browser liegt, denn läge es an der Codierung, hätte ich mit allen japanischsprachigen Websites Probleme.
Das Problem scheint aber nur da zu sein, wo sich Japanisch inmitten lateinischer Schrift befindet oder so wie hier im Forum. Das fehlerhafte Beispiel oben ist übrigens aus meinem Livejournal, auch eine eigentlich "westliche" Seite.

Wie kann ich prüfen, welche Schriftart mein Browser auf einer Webseite verwendet?
01.02.07 20:41
Alle Beiträge dieses Benutzers finden Diese Nachricht in einer Antwort zitieren
Boku


Beiträge: 288
Beitrag #5
RE: Mein Browser verschluckt einzelne Kanji.
Wenn du kein MS Office installiert hast dann ist auf deinem System nur ein teilbelegter Unicode Font installiert. (sprich manche Kanji fehlen).
Soweit ich weiss installiert erst MS Office diesen 20MB fetten "Arial Unicode MS" der so ziemlich alle Unicodezeichen darstellen kann.
Dieser Font sollte dann verwendet werden wenn ein anderer keine passenden Glyphen findet.

Manchmal ist auch die Deafaultfonteinstellung falsch.
(Wenn ein ausgewaehlter Font einen Glyphen nicht findet, verwendet das System den Defaultfont).
Kann mich aber momentan nicht erinnern welcher Registrykey das ist.
Bei Bedarf, Google hilft...
02.02.07 01:37
Alle Beiträge dieses Benutzers finden Diese Nachricht in einer Antwort zitieren
Mein Browser verschluckt einzelne Kanji.
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
Mein neues Sumaho Yano 22 1.124 14.01.18 08:48
Letzter Beitrag: 客人
IME zeigt Kanji nicht an Nemi 23 1.950 12.10.17 12:56
Letzter Beitrag: Nia
Kanji-Anzeige unvollständig - Font-Problem? afi 29 5.653 07.10.14 21:11
Letzter Beitrag: Hellstorm
Kanji Sortierung unter Windows Kevin 5 1.689 17.02.14 23:42
Letzter Beitrag: torquato
Kanji Quick boyfriend 15 5.480 18.11.12 05:36
Letzter Beitrag: yamaneko